Page 3 of 3 FirstFirst 123
Results 31 to 38 of 38

Thread: Over heating only with AC on

  1. #31
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,138
    Quote Originally Posted by RubberCtyRauder View Post
    Car is 05 crown Vic, not 32v, and a tune can change when fan comes on temp wise
    and yes , its a 05 crown vic

  2. #32
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,138
    Update

    Ok so drove to harbor freight and bought a radiator pressure test kit. Got home and went at it. Gave it 16psi of pressure and pressure started dropping. I then herd drips. Found that the clamp on the lower radiator hose where it connects to the oil filter adaptor wasnt making enough force to keep the hose tight. Replaced the clamp.

    Tested the system again and gave it 16psi. Didnt give it much time just maybe 2 mins and didnt see no drop. Put the cap back on and went for an hour drive. Got home and went to remove the reservoir cap and no god damn pressure. Tested the pressure with the test kit and this time left it hooked up for 15 mins. Gave it 17psi and 15 mins later lost 3psi. Couldnt find no leak no where.

    So now what?

  3. #33
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,138
    Just want to inform that i have resolved my issue. Bought all new heavy duty blue silicon hoses for a p71. Also bought all new clamps. Purchased a new reservoir and cap and a brand new oem motorcraft fan and motorcraft waterpump, just in case. Also installed my stock oem water pump pulley and crank pulley. Took my steedas of. System now holds pressure and no over heating. Ac is even colder.

    Want to thank all for your inputs and time. Greatly appriciate the web site.
    Last edited by crownvic05; 07-20-2019 at 03:46 PM.

  4. #34
    Join Date
    Jul 2019
    Location
    Dallas Texas
    Age
    26
    Posts
    1
    I wonder will that be the solution for my Marauder Iím having the same exact problem after putting a new block in my car it starts overheating with the ac on


    Sent from my iPhone using Tapatalk

  5. #35
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,138
    Update guys, so i fixed the issue with the system not holding pressure. Thats great. Seems like the over heating with ac on is still happenning. Today temp was up in the 101 feeling 110. In heavy stop and go traffic, car started getting hot. Plugged in my sct to data log the coolant temp. Hit the 103 celcius which is 217 f. Had to shut off and temp started dropping. I beleive that the issue might be the ac compressor. It has a none stop ticking noise. Might be failing causing overload. Ive read that its possible.

    Back to step one.

  6. #36
    Join Date
    Oct 2003
    Location
    Beaufort, SC
    Posts
    7,616
    217* ain't too bad under those conditions.....mine hit 228* in stop and go traffic once with a 105* ambient!!

    Does the temperature stabilize when you are moving at about 45 MPH??
    Member #1368
    2004 Silver Birch...300A
    #948 of 3213/#8787 of 11052
    FIT "ProCharger" #0010
    Real AutoMeter Oil Pressure Gauge
    Addco Anti-Sway Bars
    ScanGauge II In Dash
    Nitto 295's On Widened Rears
    Mach I Air Dam

  7. #37
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,138
    228? wao thats high. But you have a procharger on your car. Creates more heat?

    The fact that this only happens with AC on, implies that theres some kind of issue. This week wont be that bad. I will drive her and see what happens. Weather shouldnt reach 90's this week.
    to be continue

  8. #38
    Join Date
    Oct 2003
    Location
    Beaufort, SC
    Posts
    7,616
    I turned the AC off and it fell to 215* or so.......do some research on AC condenser heat......it will SHOCK you!!
    Member #1368
    2004 Silver Birch...300A
    #948 of 3213/#8787 of 11052
    FIT "ProCharger" #0010
    Real AutoMeter Oil Pressure Gauge
    Addco Anti-Sway Bars
    ScanGauge II In Dash
    Nitto 295's On Widened Rears
    Mach I Air Dam

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •