Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 53

Thread: Over heating only with AC on

  1. #31
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,158
    Quote Originally Posted by RubberCtyRauder View Post
    Car is 05 crown Vic, not 32v, and a tune can change when fan comes on temp wise
    and yes , its a 05 crown vic

  2. #32
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,158
    Update

    Ok so drove to harbor freight and bought a radiator pressure test kit. Got home and went at it. Gave it 16psi of pressure and pressure started dropping. I then herd drips. Found that the clamp on the lower radiator hose where it connects to the oil filter adaptor wasnt making enough force to keep the hose tight. Replaced the clamp.

    Tested the system again and gave it 16psi. Didnt give it much time just maybe 2 mins and didnt see no drop. Put the cap back on and went for an hour drive. Got home and went to remove the reservoir cap and no god damn pressure. Tested the pressure with the test kit and this time left it hooked up for 15 mins. Gave it 17psi and 15 mins later lost 3psi. Couldnt find no leak no where.

    So now what?

  3. #33
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,158
    Just want to inform that i have resolved my issue. Bought all new heavy duty blue silicon hoses for a p71. Also bought all new clamps. Purchased a new reservoir and cap and a brand new oem motorcraft fan and motorcraft waterpump, just in case. Also installed my stock oem water pump pulley and crank pulley. Took my steedas of. System now holds pressure and no over heating. Ac is even colder.

    Want to thank all for your inputs and time. Greatly appriciate the web site.
    Last edited by crownvic05; 07-20-2019 at 03:46 PM.

  4. #34
    Join Date
    Jul 2019
    Location
    Dallas Texas
    Age
    26
    Posts
    1
    I wonder will that be the solution for my Marauder Iím having the same exact problem after putting a new block in my car it starts overheating with the ac on


    Sent from my iPhone using Tapatalk

  5. #35
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,158
    Update guys, so i fixed the issue with the system not holding pressure. Thats great. Seems like the over heating with ac on is still happenning. Today temp was up in the 101 feeling 110. In heavy stop and go traffic, car started getting hot. Plugged in my sct to data log the coolant temp. Hit the 103 celcius which is 217 f. Had to shut off and temp started dropping. I beleive that the issue might be the ac compressor. It has a none stop ticking noise. Might be failing causing overload. Ive read that its possible.

    Back to step one.

  6. #36
    Join Date
    Oct 2003
    Location
    Beaufort, SC
    Posts
    7,656
    217* ain't too bad under those conditions.....mine hit 228* in stop and go traffic once with a 105* ambient!!

    Does the temperature stabilize when you are moving at about 45 MPH??
    No Marauder

  7. #37
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,158
    228? wao thats high. But you have a procharger on your car. Creates more heat?

    The fact that this only happens with AC on, implies that theres some kind of issue. This week wont be that bad. I will drive her and see what happens. Weather shouldnt reach 90's this week.
    to be continue

  8. #38
    Join Date
    Oct 2003
    Location
    Beaufort, SC
    Posts
    7,656
    I turned the AC off and it fell to 215* or so.......do some research on AC condenser heat......it will SHOCK you!!
    No Marauder

  9. #39
    Join Date
    Jan 2015
    Location
    Mishawaka, In
    Posts
    654
    Your a/c condenser fins are dirty and sending hot air across the radiator


    Sent from my iPhone using Tapatalk

  10. #40
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,158
    So i just ordered ac condenser, accumulator, compressor and orifice tube. All parts are motorcraft and throught rockauto with the beautiful 5% off.
    I am determine to have this issue resolved. My ac condenser, the fins are pretty much crushed especially towards the bottom.

    I will report hopefully next week when i get all this installed.
    Today weather was at 83. Ac was on high. Temp was rising slowly and made it to 204 before i shut off the ac and temp lowered pretty fast to 194 and sat there. When ac is on, i can feel the engine some what stall. I have a feeling that my 170k mile compressor is close toast especially with that none stop clicking noise. Also the fact that the ac condensor isent moving much air through because of the crushed fins can also be an issue for ventilation.

  11. #41
    Join Date
    Aug 2011
    Location
    Wisconsin
    Posts
    3,765
    Does the fan kick on when you turn the a/c on?

    WLB
    BB#1) 1996 ImpalaSS - 16,500 miles - 100% stock
    ______________________________ ___________

    BB#2) 2003 Marauder (300a) - 34k miles - Daily Driver
    #2912 of 7093
    Conceived 8/6/2002
    Delivered 9/19/2002
    Adopted 8/10/2011
    Trilogy 242 - Self Installed 9/9/12 (0-60 5.5 sec)
    Pioneer 6x8 Front
    Legacy 600w 6x9 Rears
    JL 6.5 SubWoofer
    K&N CAI
    Window tint 50% rear/35% front
    FBM CHMSL with Strobe mod 7/1/12
    DR Deep Aluminum Trans Pan
    Sparta FOMOCO Racing 8.8 Girdle
    Mo's Dyno Tune
    Gorilla Nuts - The System
    Ford Racing 4.10s, 31 spline Cobra carrier & axles 7/1/12
    Powder Coat Axle Housing 7/1/12
    CME HP Rear Control Arms & Watts Link 7/1/12
    ______________________________ ________________

    Rex "SC Cheesehead" Weinbender 11-14-13
    Ed "Baaad GN" Linthicum 8-6-2014

  12. #42
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,158
    Quote Originally Posted by MyBlackBeasts View Post
    Does the fan kick on when you turn the a/c on?

    Yes it does.

  13. #43
    Join Date
    Oct 2003
    Location
    Beaufort, SC
    Posts
    7,656
    Does the fan run on HIGH SPEED when the AC is on??
    No Marauder

  14. #44
    Join Date
    Jan 2015
    Location
    Mishawaka, In
    Posts
    654
    A/C compressor constantly clicking can be low refrigerant, or high pressure switch sensing hot temperatures, either way seems like youíre going to address the entire thing.


    Sent from my iPhone using Tapatalk

  15. #45
    Join Date
    Feb 2011
    Location
    New Jersey
    Age
    36
    Posts
    1,158
    Quote Originally Posted by mm svt View Post
    A/C compressor constantly clicking can be low refrigerant, or high pressure switch sensing hot temperatures, either way seems like you’re going to address the entire thing.


    Sent from my iPhone using Tapatalk
    Took the car to my mechanic real quick to check the refrigerant. Pressure was suoer high. They vacuumed the system, and filled it again. No leaks also. I will drive it and test it now. Mechanic did say that the none clicking is not normal and compressor will take a crap sooner then later. Anyways, received the condenser today. All other parts getting to me by friday the latest.

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •