Results 1 to 3 of 3

Thread: Audio/Alternator/Overcharging Problem, looking for advice.

  1. #1
    Join Date
    Jun 2017
    Location
    Essex County, Massachusetts
    Age
    38
    Posts
    19

    Audio/Alternator/Overcharging Problem, looking for advice.

    Need a little help with an electrical problem. Recently had an audio system installed with speakers, subs and an amp. It was done by a reputable audio place, not a teenager at best buy. Long story short, I took the car into my mechanic for what I thought was a battery/alternator problem. (Car would not start if sat for longer than 3-4 days) They tested the battery and said it had a dead cell. and said my alternator was only charging at 13 volts. I replaced the battery, and had the alternator rebuilt. With new battery and rebuilt alternator, it was overcharging the battery at 17 volts. The only way my mechanic could stop this was to disconnect the amp for my subs. Taking it back to the audio installer, but curious if anyone has any ideas? Thanks in advance.

  2. #2
    Join Date
    Feb 2014
    Location
    birmingham, al
    Age
    31
    Posts
    121
    Make sure the amp has a good ground, if so try a new grounding spot

    Sent from my SM-G965U using Tapatalk

  3. #3
    Join Date
    Jun 2017
    Location
    Essex County, Massachusetts
    Age
    38
    Posts
    19
    Thanks for the input, When I picked the car up from my mechanic I drove it straight to the audio installer. He touched the disconnected amp wire to the battery, which powered up the radio/subs, and tested the battery simultaneously. It stayed right at 14.7, even with me revving the engine up. He left it disconnected and told me to drive the car for a few days to make sure everything is normal and then I will leave it with him for a day to sort out whatever could be going on. I will mention checking the ground wire to him for sure. thanks again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trunk / Luggage Compartment light problem and or ?
    By jaywish in forum Interior Electrical/Electronics
    Replies: 3
    Last Post: 08-14-2019, 02:36 PM
  2. Alternator Regulator Part Number
    By pantheroc in forum Shop Talk
    Replies: 2
    Last Post: 07-11-2019, 04:26 PM
  3. shifting problem?
    By mark in forum Transmissions
    Replies: 23
    Last Post: 11-23-2016, 09:00 PM
  4. New member problem
    By Sidney in forum The Lounge
    Replies: 25
    Last Post: 02-05-2003, 06:29 AM
  5. Audio components
    By jjfingers in forum Community Discussion
    Replies: 2
    Last Post: 10-22-2002, 07:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •