Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Questions about front end parts

  1. #1
    Join Date
    Mar 2014
    Location
    Tampa, FL
    Age
    29
    Posts
    518

    Questions about front end parts

    Hello, all. Over the past couple of months, I decided to garage the Marauder to do some little repairs and refresh some worn out parts. Mostly hoses, seals, fluids and the like, but a few small body parts as well.

    When taking out the headlights for proper restoration, I decided I would take off the grille to make getting them out easier. I've taken out the headlights before without removing anything else, but I decided I would take the grille off too since it would be parked for a while. What an awful mistake. Upon removing the upper nuts that hold it to the header panel, I noticed that one of the upper tabs was already broken, and the second one was halfway snapped off. I then carefully but unsuccessfully tried to remove the bottom tabs, which resulted in every single brittle tab breaking off. I had heard the grilles on these cars were brittle and hard to remove, but WOW. I'm assuming by looking at it that I have a worthless hunk of plastic on my hands now. Anyone have experience with an aftermarket painted grille as a replacement option? Anyone have a spare OEM grille they're willing to sell?

    Well, after that disaster, I decided I would tear apart the whole front end fascia so I could replace any worn out skid plates and/or air dams and have the front bumper cover painted. When removing the fascia and skid plates, I noticed a few things and wanted to confirm with other Marauder owners for reference.

    First of all, I noticed that my radiator support looks like it may have ever-so-slightly buckled in the middle. This could have happened if the car bottomed out somewhere during its life. First picture shows a side view with the bottom of the support circled in red. Can someone confirm OEM shape of the bottom support? Only thing fooling me is how uniform and centered the peak is in the middle. No scrapes, dings, etc.

    Second, I noticed this irregularity a while ago but I'm just getting around to asking about it. On the front right wheel well, there's a debris shield in front of the tire. On the front left wheel well, there is no shield on my car. Anyone have a part number for the missing part? Odd thing is that it doesn't look like anything is missing, aside from the big gap between the tire and the inside of the fender. Second and third pictures show the left versus right wheel wells.

    Third, when taking apart the skid plates and air deflectors that attach to the bumper cover, I noticed that it looks like the very ends of my front fenders have been deformed! Maybe this could've happened if the car bottomed out over a steep curb or hump in the road? I took pictures and then highlighted them to bring attention to the parts in questions. Red line shows how it is currently shaped and yellow line shows what I think it's supposed look like, though I need confirmation to be sure. Fourth and fifth pictures show the parts.

    Lastly, what is this rubber piece and where do I get a replacement like it? Mine are worn out and nasty looking, but they don't have a part number on them. When I look up the part number for the air deflector they're attached to (6W7Z8327C), the results never include that piece. Sixth picture shows the part.

    Thanks in advance for anyone who can confirm with pictures of their own or by eyeballing their cars and reporting back. Unfortunately, reference pictures, diagrams, and parts are getting harder and harder to find for these cars!








    Last edited by HotRaud90; 03-23-2020 at 08:16 AM.
    2003 Black 300A
    Adopted: 4/26/14

    Mods:
    Mo's Tune - K&N CAI - 4.10 FOMOCO gears - Reische 170* T-stat - NGK TR6 Plugs - Flowmaster 40s - MuscleMerc's 3" Fuel Filter Mod - Addco Front and Rear Sway Bars - TCE SS Brake Lines - Cooper RS3-G1 - Factory Spoiler - SS Bumper Inserts

  2. #2
    Join Date
    Jun 2011
    Location
    Northeast OH
    Posts
    7,584
    Pics don't work, I quite certain no splash shield on driver side. My guess is the curb side has more water due to road crown, curb, run off...
    2004 SB Ported Trilogy 48
    Has supporting mods and stuff
    Thanks to Marty O for his help in updating this car.

    R.I.P.
    Rex "SC Cheesehead"

  3. #3
    Join Date
    Mar 2014
    Location
    Tampa, FL
    Age
    29
    Posts
    518
    Quote Originally Posted by RubberCtyRauder View Post
    Pics don't work, I quite certain no splash shield on driver side. My guess is the curb side has more water due to road crown, curb, run off...
    Hm, that's odd. They're showing for me on Tapatalk and on the website when I click on them. Did you try scrolling over and clicking on the attachment links at the bottom of my original post? They're not showing up as pictures, but rather as links.
    2003 Black 300A
    Adopted: 4/26/14

    Mods:
    Mo's Tune - K&N CAI - 4.10 FOMOCO gears - Reische 170* T-stat - NGK TR6 Plugs - Flowmaster 40s - MuscleMerc's 3" Fuel Filter Mod - Addco Front and Rear Sway Bars - TCE SS Brake Lines - Cooper RS3-G1 - Factory Spoiler - SS Bumper Inserts

  4. #4
    Join Date
    May 2009
    Location
    Moreau Island
    Posts
    11,641
    pics working on my computer.

  5. #5
    Join Date
    Dec 2002
    Location
    north nj (Planet Houston)
    Posts
    703
    "Invalid Attachment specified. If you followed a valid link, please notify the administrator" when i click on them (I'm on desktop)
    "Come to me, Superman! I defy you! Come and kneel before Zod! Zod! "

  6. #6
    Join Date
    Mar 2014
    Location
    Tampa, FL
    Age
    29
    Posts
    518
    The picture uploading process on this website is, well...far from polished. I'll see what I can do to rectify the problem. Weird that it works for some and not for others.
    2003 Black 300A
    Adopted: 4/26/14

    Mods:
    Mo's Tune - K&N CAI - 4.10 FOMOCO gears - Reische 170* T-stat - NGK TR6 Plugs - Flowmaster 40s - MuscleMerc's 3" Fuel Filter Mod - Addco Front and Rear Sway Bars - TCE SS Brake Lines - Cooper RS3-G1 - Factory Spoiler - SS Bumper Inserts

  7. #7
    Join Date
    Aug 2011
    Location
    Pacific Northwest
    Age
    18
    Posts
    1,978
    Quote Originally Posted by the fat bastid View Post
    "Invalid Attachment specified. If you followed a valid link, please notify the administrator" when i click on them (I'm on desktop)
    I get the same.

  8. #8
    Join Date
    Mar 2014
    Location
    Tampa, FL
    Age
    29
    Posts
    518
    Quote Originally Posted by RubberCtyRauder View Post
    Pics don't work, I quite certain no splash shield on driver side. My guess is the curb side has more water due to road crown, curb, run off...
    Quote Originally Posted by Mr. Man View Post
    pics working on my computer.
    Quote Originally Posted by the fat bastid View Post
    "Invalid Attachment specified. If you followed a valid link, please notify the administrator" when i click on them (I'm on desktop)
    Quote Originally Posted by NXSBOB View Post
    I get the same.
    Alright, I attempted to do an overhaul of the photos in order to get them to work. I put them directly in the post this time rather than attachments. I'm getting functioning pictures on my end. Hopefully it's the same for everyone else.
    2003 Black 300A
    Adopted: 4/26/14

    Mods:
    Mo's Tune - K&N CAI - 4.10 FOMOCO gears - Reische 170* T-stat - NGK TR6 Plugs - Flowmaster 40s - MuscleMerc's 3" Fuel Filter Mod - Addco Front and Rear Sway Bars - TCE SS Brake Lines - Cooper RS3-G1 - Factory Spoiler - SS Bumper Inserts

  9. #9
    Join Date
    Jun 2011
    Location
    Northeast OH
    Posts
    7,584
    Looks like you are missing the stiffener rod on the one side, visible on the other side
    2004 SB Ported Trilogy 48
    Has supporting mods and stuff
    Thanks to Marty O for his help in updating this car.

    R.I.P.
    Rex "SC Cheesehead"

  10. #10
    Join Date
    Mar 2014
    Location
    Tampa, FL
    Age
    29
    Posts
    518
    Quote Originally Posted by RubberCtyRauder View Post
    Looks like you are missing the stiffener rod on the one side, visible on the other side
    I have it. It was already removed from the car when I took that picture.
    2003 Black 300A
    Adopted: 4/26/14

    Mods:
    Mo's Tune - K&N CAI - 4.10 FOMOCO gears - Reische 170* T-stat - NGK TR6 Plugs - Flowmaster 40s - MuscleMerc's 3" Fuel Filter Mod - Addco Front and Rear Sway Bars - TCE SS Brake Lines - Cooper RS3-G1 - Factory Spoiler - SS Bumper Inserts

  11. #11
    Join Date
    Nov 2004
    Location
    Smithfield, Virginia
    Age
    49
    Posts
    19,054
    The pic with the question mark, useless piece of crap. I took mine off at about 25 thousand miles due to warping and sagging and looking stupid. Shaved .000005 seconds off my 1/4 mile time so there's that.


    ~But, it makes it a lot easier when he is manscaped.~ Haggis
    ~Cool, I can have one of those strangulation orgasms without the strangle.
    WIN WIN!~ Zack
    ~Who needs to stop? I just wanna gooooooooooo ~ -Matt-

  12. #12
    Join Date
    Jun 2003
    Location
    Timbuk3, MI
    Posts
    2,262

    Post

    HotRaud90 ..... On the front left wheel well, there is no shield on my car. Anyone have a part number for the missing part?...

    3W7Z-16240-BA - Splash Shield (LH) ««« -click-
    .

  13. #13
    Join Date
    Mar 2008
    Location
    Couple of car lengths ahead of you
    Age
    46
    Posts
    19,377

    Questions about front end parts

    Sorry, I have literally none of that stuff installed anymore. Between all those pieces, hardware, and all the radiator air damns that you haven’t even got to yet, it would take some serious head scratching to remember it all!

    Post 2 is spot on. The shield from what I remember is the actual inner wheel well, drivers side just doesn’t go down as far. Yep, trimmed off pieces of both of them as well.
    Sent from my iPhone using Tapatalk Pro


    Cobra short block / ProCharger F1-A / Cog drive upgrade / Manley valves / Brian Tooley Racing valve springs / 80# inj. / -8 fuel line / -6 return / Aeromotive 340 pumps and regulator / 2012 GT500 TR6060 six speed / twin disc clutch / Driveshaft Shop GT500 upgraded CV joint shaft / BA5000 blow thru MAF/ 4.10's / Ford Racing 31 spline set up and Girdle / Metco D.S. safety loop / Stainless Works headers, cats, and everything else out back / ClassGlass hood / Bob's hood strut mod / Hurst line lock / Metco control arms / Addco front and rear sway bars / Monroe severe duty shocks all around / Race concepts rotors / Badgeless grille / 35% tint / FBM's interior LED kit and ambient lighting kit / Pioneer FB700 deck / kenwood speaker 4 Ch. / Rockford Fosgate 10" sub and amp / Kicker 6 X 8's all around / back up cam / bluetooth / Pioneer Xm / 704 RWHP 603 RWTQ tuned by Mo's Speedshop.

  14. #14
    Join Date
    Mar 2014
    Location
    Tampa, FL
    Age
    29
    Posts
    518
    Quote Originally Posted by CBT View Post
    The pic with the question mark, useless piece of crap. I took mine off at about 25 thousand miles due to warping and sagging and looking stupid. Shaved .000005 seconds off my 1/4 mile time so there's that.
    Fair enough! I have stickers that I can put on to lower my 1/4 mile time, though, so there's no need to remove mine for good.

    Quote Originally Posted by gdmjoe View Post

    3W7Z-16240-BA - Splash Shield (LH) ««« -click-
    .
    Gdmjoe, thanks for the part reference, but I think that part particular part may be the splash guard that blocks water from going into the engine bay through the strut tower cavity. I think its the part that covers the upper portion of the strut assembly.

    Quote Originally Posted by justbob View Post
    Sorry, I have literally none of that stuff installed anymore. Between all those pieces, hardware, and all the radiator air damns that you haven’t even got to yet, it would take some serious head scratching to remember it all!

    Post 2 is spot on. The shield from what I remember is the actual inner wheel well, drivers side just doesn’t go down as far. Yep, trimmed off pieces of both of them as well.
    Sent from my iPhone using Tapatalk Pro
    Not surprised . By the way, radiator air dams are already off, but they're not pictured. I don't have any questions about those Now if I can just remember how all the screws and bolts go back in...

    Thanks for what info has been shared so far, everyone. That's interesting about the driver's side wheel well shield. Why in the hell would they make one side longer than the other? It legitimately looks like something is missing from the factory. The inside of the bumper gets nasty without one. The amount of crap that came out after taking off the bumper shields and deflectors? Blech!

    Anyone else have any input to share about the lower portion of the front fenders that bolt to the front bumper/air deflectors? Thinking I may have to find a way to reshape the metal in the case that they are indeed bent...
    2003 Black 300A
    Adopted: 4/26/14

    Mods:
    Mo's Tune - K&N CAI - 4.10 FOMOCO gears - Reische 170* T-stat - NGK TR6 Plugs - Flowmaster 40s - MuscleMerc's 3" Fuel Filter Mod - Addco Front and Rear Sway Bars - TCE SS Brake Lines - Cooper RS3-G1 - Factory Spoiler - SS Bumper Inserts

  15. #15
    Join Date
    Mar 2008
    Location
    Couple of car lengths ahead of you
    Age
    46
    Posts
    19,377
    Be cautious on coolant temps with deflectors removed. More than one person took them off only to find overheating issues in certain traffic conditions.

    Mine are eliminated because my custom radiator has been relocated and raked back. It was trial and error that worked luckily on the first go round.


    Sent from my iPhone using Tapatalk Pro


    Cobra short block / ProCharger F1-A / Cog drive upgrade / Manley valves / Brian Tooley Racing valve springs / 80# inj. / -8 fuel line / -6 return / Aeromotive 340 pumps and regulator / 2012 GT500 TR6060 six speed / twin disc clutch / Driveshaft Shop GT500 upgraded CV joint shaft / BA5000 blow thru MAF/ 4.10's / Ford Racing 31 spline set up and Girdle / Metco D.S. safety loop / Stainless Works headers, cats, and everything else out back / ClassGlass hood / Bob's hood strut mod / Hurst line lock / Metco control arms / Addco front and rear sway bars / Monroe severe duty shocks all around / Race concepts rotors / Badgeless grille / 35% tint / FBM's interior LED kit and ambient lighting kit / Pioneer FB700 deck / kenwood speaker 4 Ch. / Rockford Fosgate 10" sub and amp / Kicker 6 X 8's all around / back up cam / bluetooth / Pioneer Xm / 704 RWHP 603 RWTQ tuned by Mo's Speedshop.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I've got a few parts questions, please help!
    By Chatam/Marauder in forum Community Discussion
    Replies: 7
    Last Post: 12-22-2012, 10:39 AM
  2. For Sale 03 MM front end parts
    By bigcowl-imp in forum bigcowl-imp's garage sale
    Replies: 4
    Last Post: 04-16-2011, 07:42 AM
  3. MM vs CV Sport Floor Shifter Parts/Tech Questions
    By the_pack_rat in forum Community Discussion
    Replies: 9
    Last Post: 02-16-2005, 11:16 AM
  4. Two parts questions
    By Fourth Horseman in forum Shop Talk
    Replies: 14
    Last Post: 08-09-2003, 12:12 AM
  5. Parts & Questions
    By ts-pa in forum Shop Talk
    Replies: 7
    Last Post: 12-12-2002, 11:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •