Results 1 to 9 of 9

Thread: AC system issues

  1. #1
    Join Date
    Apr 2020
    Location
    Spokane WA
    Age
    22
    Posts
    11

    AC system issues

    Alrighty boys, it's mid june, which means it's time for AC questions.

    Two weeks ago, as I was cruising down the highway in phoenix, the AC went from blowing nice and cold to ambient temp for about 20 minutes. I assumed it was an EATC issue, and left it for the time being.

    Yesterday, on my way from San Diego to Phoenix, the AC died in Blythe CA. I assumed it was the EATC acting up, so I removed it from its slot, removed the glovebox, and verified that all the vacuum actuators and the blend door actuator works (they do). I also topped up the R-134A, it took about 3 seconds until it was at the correct low side running pressure of 55psi.

    Today, the AC didn't pretend to blow cold, and when I got on the freeway there was a buzzing sound and a noticeable lurch each time the compressor engaged. After some more driving, it became apparent that below 1500 rpm, the AC would work normally and it would blow about 60* at the vents, above 1500 rpm it does the buzzing lurching thing and blows at ambient temp.

    Am I in for a new compressor/clutch/orifice tube & co., or is there something else I should look at first? Thanks

  2. #2
    Join Date
    Apr 2010
    Location
    South Florida
    Age
    30
    Posts
    1,597
    I'd say replace the compressor, drier, and orfice tube. It shouldn't just take 3 seconds to charge the system. It has to be done with the machine. To recover it and recharge after vacuum You're looking at 15-20 mins. Have a professional add some dye into it and check with the violet light for leaks.


    Sent from my iPhone using Tapatalk Pro

  3. #3
    Join Date
    Oct 2003
    Location
    Beaufort, SC
    Posts
    7,685
    The AC's did that in my CV's and the Marauder....watched an AC man remove a shim from the AC clutch in one of my CV's.......FIXED!!

    It seems high mileage cars experience a widened AC clutch gap from wear and the magnetic exciter cannot hold the clutch firmly at higher RPM's......there are normally several shims in the compressor clutch from the factory to get the correct gap!! Removing a shim or two may do the trick.......you'll have to make or rent a tool to hold the clutch while you remove the bolt!!

    I recall about 0.015" is the max gap allowed........I removed all shims in my Marauder at around 200K miles...worked flawlessly from then on!!
    No Marauder

  4. #4
    Join Date
    Jun 2008
    Location
    Waukesha, WI
    Posts
    1,067
    Quote Originally Posted by Marauderjack View Post
    The AC's did that in my CV's and the Marauder....watched an AC man remove a shim from the AC clutch in one of my CV's.......FIXED!!

    It seems high mileage cars experience a widened AC clutch gap from wear and the magnetic exciter cannot hold the clutch firmly at higher RPM's......there are normally several shims in the compressor clutch from the factory to get the correct gap!! Removing a shim or two may do the trick.......you'll have to make or rent a tool to hold the clutch while you remove the bolt!!

    I recall about 0.015" is the max gap allowed........I removed all shims in my Marauder at around 200K miles...worked flawlessly from then on!!
    Still works at 275K!
    You "feel" the difference because you want to "feel" the difference. Since you just spent money on the upgrade you "have" to feel the difference

    I'm looking to eliminate the double pump process I have to follow right now to get the pedal hard

    2004 300A Procharger #0010 D1SC
    2003 300A Procharger #0017 D1SC (SOLD)

  5. #5
    Join Date
    Oct 2003
    Location
    Beaufort, SC
    Posts
    7,685
    TADA!!

    It really is amazing that automotive components can live that long Dave!!
    No Marauder

  6. #6
    Join Date
    Apr 2020
    Location
    Spokane WA
    Age
    22
    Posts
    11
    Thanks guys, I'll give that shim trick a shot before dropping $300 and all day on new parts. I'll let you know how it goes!

  7. #7
    Join Date
    Mar 2008
    Location
    Couple of car lengths ahead of you
    Age
    46
    Posts
    19,504
    Check for a vacuum leak. The black box on the drivers fender is a holding tank for vacuum so when you’re accelerating and making little to no vacuum it won’t effect the performance of the A/C.


    Sent from my iPhone using Tapatalk Pro


    Cobra short block / ProCharger F1-A / Cog drive upgrade / Manley valves / Brian Tooley Racing valve springs / 80# inj. / -8 fuel line / -6 return / Aeromotive 340 pumps and regulator / 2012 GT500 TR6060 six speed / twin disc clutch / Driveshaft Shop GT500 upgraded CV joint shaft / BA5000 blow thru MAF/ 4.10's / Ford Racing 31 spline set up and Girdle / Metco D.S. safety loop / Stainless Works headers, cats, and everything else out back / ClassGlass hood / Bob's hood strut mod / Hurst line lock / Metco control arms / Addco front and rear sway bars / Monroe severe duty shocks all around / Race concepts rotors / Badgeless grille / 35% tint / FBM's interior LED kit and ambient lighting kit / Pioneer FB700 deck / kenwood speaker 4 Ch. / Rockford Fosgate 10" sub and amp / Kicker 6 X 8's all around / back up cam / bluetooth / Pioneer Xm / 704 RWHP 603 RWTQ tuned by Mo's Speedshop.

  8. #8
    Join Date
    Aug 2011
    Location
    Wisconsin
    Posts
    3,892
    My clutch failed where the thin plate part of clutch cracked and would drag when disengaged and not fully engage when magnet activated.

    $80 I think from Rock auto and 45 minutes = good as new even 6 or so years later.

    WLB
    BB#1) 1996 ImpalaSS - 16,500 miles - 100% stock
    ______________________________ ___________

    BB#2) 2003 Marauder (300a) - 34k miles - Daily Driver
    #2912 of 7093
    Conceived 8/6/2002
    Delivered 9/19/2002
    Adopted 8/10/2011
    Trilogy 242 - Self Installed 9/9/12 (0-60 5.5 sec)
    Pioneer 6x8 Front
    Legacy 600w 6x9 Rears
    JL 6.5 SubWoofer
    K&N CAI
    Window tint 50% rear/35% front
    FBM CHMSL with Strobe mod 7/1/12
    DR Deep Aluminum Trans Pan
    Sparta FOMOCO Racing 8.8 Girdle
    Mo's Dyno Tune
    Gorilla Nuts - The System
    Ford Racing 4.10s, 31 spline Cobra carrier & axles 7/1/12
    Powder Coat Axle Housing 7/1/12
    CME HP Rear Control Arms & Watts Link 7/1/12
    ______________________________ ________________

    Rex "SC Cheesehead" Weinbender 11-14-13
    Ed "Baaad GN" Linthicum 8-6-2014

  9. #9
    Join Date
    Jan 2003
    Location
    Near Knoxville TN
    Age
    63
    Posts
    10,678
    My ac quit, it turned out to be the engine cooling fan. The ring around the outside edge of the blades broke and jammed against the shroud. Made a loud noise and the ac didn't cool so I thought it was the compressor but found out otherwise. I've had two of them do the exact same thing. Left that way long enough, the engine will overheat too.
    Thanks to Darrin @ BC Automotive:
    $1800 and it was worse than when he started!

    Brian (FordNut) FPG # 1458 of 7838
    03 MM 300A (Lotsa mods, 130k mi) was 303rwhp/318rwtq N/A
    then 476/410 D1SC ProCharged on stock block
    then 660/555 D1SC PC on 5.3 wet sleeved Teksid alum big bore stroker
    then 365/369 N/A on 5.3 wet sleeved Teksid alum big bore stroker
    Now 751/617 3.4L Whipple on 5.3 Boss5.0 iron big bore stroker

    03 MM 300B Silver (Mostly stock, wife's car, 300k mi) FPG # 7053 of 7838 or 49 of 417 SB
    03 MM 300B Silver, Stock, 50k mi FPG # 7134 of 7838 or 89 of 417 SB
    01 F150
    00 F150 4x4
    68 Stang FB (70 351C 4V, 4 wheel discs, project car)

    Mods listed here (some items not current): FordNut's Mods

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Replies: 7
    Last Post: 04-13-2012, 12:00 AM
  2. Anyone With a Ford System 6 Alarm System Here ?
    By the_pack_rat in forum Community Discussion
    Replies: 7
    Last Post: 02-12-2012, 07:10 AM
  3. AC Issues
    By sking in forum Shop Talk
    Replies: 0
    Last Post: 08-02-2011, 07:53 AM
  4. Replies: 6
    Last Post: 05-01-2011, 06:31 AM
  5. DRL Issues.
    By Rockettman in forum Shop Talk
    Replies: 1
    Last Post: 05-26-2009, 12:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •