Results 1 to 6 of 6

Thread: Slight Overheating

  1. #1
    Join Date
    Feb 2006
    Location
    Rosemount, MN
    Age
    56
    Posts
    2,039

    Slight Overheating

    So I was running an Auto-Cross on Sunday and I made my last run of the day in the late afternoon. As I was driving at about 10-15 mph from the course to the parking area, the transmission seemed to be stuck in 3rd gear. Then I noticed the temperature gauge was about half way between normal and hot. I let it idle for a while and it cooled back down to normal after about 3 to 5 minutes. I've never had that happen before and I've been running Auto Cross events for over 10 years. Any thoughts?

  2. #2
    Join Date
    Mar 2008
    Location
    Next door to my neighbor
    Age
    47
    Posts
    19,895
    Cooling fan running? Both engine temps and trans temps amongst others command the PCM to run the fan when needed. Make sure both fan speeds are operational.


    Sent from my iPhone using Tapatalk Pro


    Cobra short block / ProCharger F1-A / Cog drive upgrade / Manley valves / Brian Tooley Racing valve springs / 80# inj. / -8 fuel line / -6 return / Aeromotive 340 pumps and regulator / 2012 GT500 TR6060 six speed / twin disc clutch / Driveshaft Shop GT500 upgraded CV joint shaft / BA5000 blow thru MAF/ 4.10's / Ford Racing 31 spline set up and Girdle / Metco D.S. safety loop / Stainless Works headers, cats, and everything else out back / ClassGlass hood / Bob's hood strut mod / Hurst line lock / Metco control arms / Addco front and rear sway bars / Monroe severe duty shocks all around / Race concepts rotors / Badgeless grille / 35% tint / FBM's interior LED kit and ambient lighting kit / Pioneer FB700 deck / kenwood speaker 4 Ch. / Rockford Fosgate 10" sub and amp / Kicker 6 X 8's all around / back up cam / bluetooth / Pioneer Xm / 704 RWHP 603 RWTQ tuned by Mo's Speedshop.

  3. #3
    Join Date
    May 2009
    Location
    Moreau Island
    Posts
    11,889
    Is your radiator clean on the outside and not full of dead bugs and leaves?

  4. #4
    Join Date
    Aug 2012
    Location
    Kansas City
    Age
    41
    Posts
    2,909
    20 bucks says power washing the front of the radiator behind the A/C condenser will fix your issue.
    Neil
    2003 Mercury Marauder - DBP/DC
    #195, Eaton Swapped, Waiting for Engine
    2003 Mercury Marauder - BLK/DC
    #2821, 80K Mile Tagalong 2 - Wife's Daily Driver
    2004 Mercury Marauder - DTR/LF
    #963, 312K Miles, Aviator Engine, Slow Daily Driver
    1964 Mercury Marauder - BLK/BLK
    390FE, 4D HT, Staggered 18's, Cruiser
    1986 Buick Regal Grand National
    Stock Block/Heads 11.08 @ 122.39mph, 25psi

    Originally Posted by Zack
    The only diagnosis is changing it.
    I have one if you need it.
    The AEM pumps don't burn up FPDM's

    Diagnosis at my house is inspecting wires. Drink a beer. Talk about what to do next. Drink a beer. Call Jaydees to bring over his spare FPDM. Drink beer waiting for him. When he shows up with the part look at it and say hold my beer while I get in the trunk. Replace part. Cannot test drive because............ Diagnosis.

  5. #5
    Join Date
    Feb 2006
    Location
    Rosemount, MN
    Age
    56
    Posts
    2,039
    Fans were running. When I stopped and opened the hood, I could hear them running, so I put my hand between the fans and the engine and I could feel air moving just fine. Reservoir was/is at the proper level. I've just never seen this happen before and I've had the car since June of 2003. I'll take a look at the radiator more closely this weekend.

  6. #6
    Join Date
    Nov 2014
    Location
    KC
    Age
    45
    Posts
    3,413
    My god. Cool it off and pull the cot plug, fill it from that port. You saying that the reservoir looks normal makes my skin crawl because every marauder owner should know the fill level from the reservoir doesn’t mean a thing.

    You are over a gallon low on coolant, fill at cot and squeeze heater hoses.

    thank me later
    The twins2.3 whipple/aluminatorVortech V-2 lots of goodies

    Current marauders
    04 DTR totaled JUST NOW starting to part out 7-21-2021 https://youtu.be/REUxjP1BVpg

    04 Silver Birch Dark Charcoal Hardtop Whipple Supercharger
    04 Silver Birch Dark Charcoal Hardtop V2 Supercharger
    04 Silver Birch Dark Charcoal Converted
    03 DBP Light Flint #122
    03 DBP Dark Charcoal #232
    03 Silver Birch 300b Light Flint Going to fix er up
    03 Black 300a
    04 Silver Birch Dark Charcoal moonroof in the works

    04 Heaton Swapped DTR
    Joe's Wrecked DTR rebuild thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Slight overheating. Thermostat again?
    By Motorhead350 in forum Shop Talk
    Replies: 16
    Last Post: 03-07-2014, 08:09 AM
  2. slight hesitation/jerking
    By Mike827 in forum Shop Talk
    Replies: 5
    Last Post: 05-04-2011, 08:52 AM
  3. new here! (slight DUW inside)
    By a_d_a_m in forum Welcome Forum
    Replies: 7
    Last Post: 07-08-2008, 06:06 AM
  4. slight race
    By 03blackvegas in forum Community Discussion
    Replies: 2
    Last Post: 03-22-2008, 09:53 PM
  5. Slight surge in A.M.??
    By CanadaMarauder in forum Shop Talk
    Replies: 6
    Last Post: 05-21-2007, 02:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •