Page 2 of 8 FirstFirst 12345678 LastLast
Results 16 to 30 of 110

Thread: EATC o-ring repair - How to... with pics.

  1. #16
    Join Date
    Jan 2004
    Location
    Somewhere in the N.C. Triangle
    Age
    68
    Posts
    26,260
    Quote Originally Posted by Carolina Rauder View Post
    I just did my second EATC repair. The first repair I replaced the the OEM o-rings with regular rubber o-rings. This time I ordered some silicone o-rings. So put my EATC back in turn on and the same problem persists. Air STILL Blowing out of DEFROST VENT ONLY.... I then performed an EATC Self Test, and I got 888 with all displays. Which I read to be No Codes... So someone please tell me what else can be WRONG?????
    Sounds like there is still a vacuum leak. Recheck the EATC, the red connector inside the EATC, the external vacuum hoses, etc. You could also have a cracked valve body in the EATC.
    “When you can’t make them see the light, make them feel the heat.”
    Ronald Regan

    "The only way to deal with the Islamic State - these blood thirsty, blood-drunken, terrorists -
    is to kill them, keep on killing them, until you kill the last one, then you kill his pet goat."

    Lt. Colonel Ralph Peters

    “Be polite, be professional, but have a plan to kill everybody you meet.”
    "I come in peace. I didn't bring artillery. But I'm pleading with you, with tears in my eyes, if you **** with me, I'll kill you all"
    General James Mattis




  2. #17
    Join Date
    Feb 2005
    Location
    St.Louis, Mo
    Age
    67
    Posts
    3,647
    For anyone interested. I got the o-rings from here.

    http://www.oringsandmore.com/servlet...ngs/Categories

    $1.70 pack of fifty. 2.50 shipped arrived in 3 days.
    Born 03/04
    Adopted on 01/03/05

    2084 of 3213 & 691 of 983____Moonroof 185 of 335 of 1213

    Now Procharger boosted #04

  3. #18
    Join Date
    May 2006
    Location
    Cherry Hill, NJ
    Age
    75
    Posts
    242
    Quote Originally Posted by fastblackmerc View Post
    Sounds like there is still a vacuum leak. Recheck the EATC, the red connector inside the EATC, the external vacuum hoses, etc. You could also have a cracked valve body in the EATC.
    Jim - if you remember from last summer (2011), that was my problem - a cracked valve body. Since then, I found 3 more people locally with that specific problem - and one of those was a "rebuilt" unit. I don't think that most of these so-called rebuilders really knows or tests for this condition.

    Anyway, after doing the o-rings, the rest of the test for vacuum leakage is easy - the vacuum tank on the left fender well drains down very rapidly. Of course, that could still be the hoses etc., but that's still easy to test - just time consuming. Remember - I went through all this stuff earlier, never even thinking that the valve body could be cracked.

    Now that I've read quite a few posts where the 0-rings haven't helped, I'm inclined to believe the cracked valve body is to blame.
    - Randy

    2004 MM (Wine Red [it looks like wine to me!])
    XCal2/Blue Oval Chips Programming

    1996 Impala SS (12.45 NA)

  4. #19
    Join Date
    Sep 2002
    Location
    Cape Cod, MA
    Posts
    13,676
    For future reference, if the issue is that the air flow goes from vent to defrost under acceleration or when going up an incline, then returns to vent when you let off the gas, it's probably o-rings.

    If it comes out the defrost ONLY, then don't even bother doing the o-rings...that's not your problem.
    The Blackbird
    Trilogy #61
    Driveway Queen

    The Spruce Goose
    2004 Grand Marquis LS Limited Edition
    Daily Driver

  5. #20
    Join Date
    May 2006
    Location
    Cherry Hill, NJ
    Age
    75
    Posts
    242
    Quote Originally Posted by RF Overlord View Post
    For future reference, if the issue is that the air flow goes from vent to defrost under acceleration or when going up an incline, then returns to vent when you let off the gas, it's probably o-rings.

    If it comes out the defrost ONLY, then don't even bother doing the o-rings...that's not your problem.
    I think that's a capital summary!
    - Randy

    2004 MM (Wine Red [it looks like wine to me!])
    XCal2/Blue Oval Chips Programming

    1996 Impala SS (12.45 NA)

  6. #21
    Join Date
    Jan 2004
    Location
    Somewhere in the N.C. Triangle
    Age
    68
    Posts
    26,260
    Quote Originally Posted by RF Overlord View Post
    For future reference, if the issue is that the air flow goes from vent to defrost under acceleration or when going up an incline, then returns to vent when you let off the gas, it's probably o-rings.

    If it comes out the defrost ONLY, then don't even bother doing the o-rings...that's not your problem.
    Not entirely true... I've re o-ringed many EATCs where it only blew out the defrost vents....under accelerated or at idle.
    “When you can’t make them see the light, make them feel the heat.”
    Ronald Regan

    "The only way to deal with the Islamic State - these blood thirsty, blood-drunken, terrorists -
    is to kill them, keep on killing them, until you kill the last one, then you kill his pet goat."

    Lt. Colonel Ralph Peters

    “Be polite, be professional, but have a plan to kill everybody you meet.”
    "I come in peace. I didn't bring artillery. But I'm pleading with you, with tears in my eyes, if you **** with me, I'll kill you all"
    General James Mattis




  7. #22
    Join Date
    Dec 2005
    Location
    Layton, UT
    Age
    43
    Posts
    4,328
    I need to try mine again. I did this but it didn't fix anything.

    Matt H.
    (sold)2004' SB, 268rwhp/295tq
    1990 Mustang GT, Dart 363, Si-trim, T56, Holley Terminator X. 622rwhp/527tq
    2003 SVT Cobra, Posi Port 497rwhp/481tq. SCT Pro Racer Pack.
    2017 F-150, 5.0
    2013 SHO DIB Performance Pack

  8. #23
    Join Date
    Nov 2003
    Location
    Monroe, NC.
    Age
    56
    Posts
    580
    Quote Originally Posted by fastblackmerc View Post
    Sounds like there is still a vacuum leak. Recheck the EATC, the red connector inside the EATC, the external vacuum hoses, etc. You could also have a cracked valve body in the EATC.
    I had the same concern and I found that the supply line under the wiper cowl was chaffed and that was why it came out of the Defrost only.
    Russ, Monroe NC.

  9. #24
    Join Date
    Sep 2002
    Location
    Cape Cod, MA
    Posts
    13,676
    Quote Originally Posted by fastblackmerc View Post
    Not entirely true... I've re o-ringed many EATCs where it only blew out the defrost vents....under accelerated or at idle.
    I bow to the master...

    I suppose if one or more of the o-rings were bad enough, all the vacuum would leak past and the unit would be stuck on defrost.
    The Blackbird
    Trilogy #61
    Driveway Queen

    The Spruce Goose
    2004 Grand Marquis LS Limited Edition
    Daily Driver

  10. #25
    Join Date
    Feb 2006
    Location
    middle of iowa
    Age
    41
    Posts
    2,772
    Quote Originally Posted by RF Overlord View Post
    For future reference, if the issue is that the air flow goes from vent to defrost under acceleration or when going up an incline, then returns to vent when you let off the gas, it's probably o-rings.

    If it comes out the defrost ONLY, then don't even bother doing the o-rings...that's not your problem.

    Mine was coming out only the vents right before I did the o-rings... but it started out chaning on its own under moderate acceleration

  11. #26
    Join Date
    Aug 2011
    Location
    Wisconsin
    Posts
    4,338
    Quote Originally Posted by 1stMerc View Post
    For anyone interested. I got the o-rings from here.

    http://www.oringsandmore.com/servlet...ngs/Categories

    $1.70 pack of fifty. 2.50 shipped arrived in 3 days.
    I readily recommend this vendor. My 1st order got lost in mail and they replaced it and refunded my original payment. The replacement shipment arrived yesterdy. 50 o-rings for $0.00

    WLB
    BB#1) 1996 ImpalaSS - 16,500 miles - 100% stock
    ______________________________ ___________

    BB#2) 2003 Marauder (300a) - 34k miles - Daily Driver
    #2912 of 7093
    Conceived 8/6/2002
    Delivered 9/19/2002
    Adopted 8/10/2011
    Trilogy 242 - Self Installed 9/9/12 (0-60 5.5 sec)
    Pioneer 6x8 Front
    Legacy 600w 6x9 Rears
    JL 6.5 SubWoofer
    K&N CAI
    Window tint 50% rear/35% front
    FBM CHMSL with Strobe mod 7/1/12
    DR Deep Aluminum Trans Pan
    Sparta FOMOCO Racing 8.8 Girdle
    Mo's Dyno Tune
    Gorilla Nuts - The System
    Ford Racing 4.10s, 31 spline Cobra carrier & axles 7/1/12
    Powder Coat Axle Housing 7/1/12
    CME HP Rear Control Arms & Watts Link 7/1/12
    ______________________________ ________________

    Rex "SC Cheesehead" Weinbender 11-14-13
    Ed "Baaad GN" Linthicum 8-6-2014

  12. #27
    Join Date
    Jul 2004
    Location
    Smyrna,Ga
    Age
    50
    Posts
    557
    is there anyone here in Georgia who knows how to do this?
    VORTECH A2A supercharger ,accufab 60mm throttle body,all fluids royal purple,cobra headers and exhaust by todd at Grands,410 gears rebuilt rearend(eaton), 3600 high stall converter,rebuilt transmission by Team Ford of marietta rear girdle,powerslot cryo disc, and stainless steel lines from dennis and tuned by aric at INJECTED INGINEERING

  13. #28
    Join Date
    Jan 2004
    Location
    Somewhere in the N.C. Triangle
    Age
    68
    Posts
    26,260
    Quote Originally Posted by bigmerc'03 View Post
    is there anyone here in Georgia who knows how to do this?
    If there is no one local, send it to me.
    “When you can’t make them see the light, make them feel the heat.”
    Ronald Regan

    "The only way to deal with the Islamic State - these blood thirsty, blood-drunken, terrorists -
    is to kill them, keep on killing them, until you kill the last one, then you kill his pet goat."

    Lt. Colonel Ralph Peters

    “Be polite, be professional, but have a plan to kill everybody you meet.”
    "I come in peace. I didn't bring artillery. But I'm pleading with you, with tears in my eyes, if you **** with me, I'll kill you all"
    General James Mattis




  14. #29
    Join Date
    Jul 2010
    Location
    Guntersville Al.
    Age
    60
    Posts
    1,291
    I know how to do it, I just don't have te stuff to do it with. And I'll be in Chattanooga this Saturday.

    It was an honor to have
    my ASS kicked by you!
    Rest In Peace!
    Paul T. Casey

  15. #30
    Join Date
    Sep 2002
    Location
    Cape Cod, MA
    Posts
    13,676
    heh...oringsandmore.com Sounds like of of those direct-marketing ads on late night TV:

    "But wait! We'll double your order to 10,000 o-rings absolutely free! Just pay separate shipping and processing...






    ...of $29.95"
    The Blackbird
    Trilogy #61
    Driveway Queen

    The Spruce Goose
    2004 Grand Marquis LS Limited Edition
    Daily Driver

Page 2 of 8 FirstFirst 12345678 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. EATC Repair
    By fastblackmerc in forum Marauder Innovations
    Replies: 25
    Last Post: 06-18-2015, 04:43 AM
  2. Eatc repair success
    By marauder410 in forum Shop Talk
    Replies: 3
    Last Post: 06-06-2012, 01:19 AM
  3. Eatc repair??
    By biggeorge04 in forum Shop Talk
    Replies: 6
    Last Post: 09-23-2011, 10:10 PM
  4. EATC Repair
    By PonyUP in forum Southern Marauders
    Replies: 52
    Last Post: 06-28-2011, 06:13 PM
  5. Did the O-ring EATC repair...few questions.
    By 68Camaro in forum Shop Talk
    Replies: 5
    Last Post: 05-14-2010, 07:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •