MercuryMarauder.net Forums    

Go Back   MercuryMarauder.net Forums > The Garage > Shop Talk

Shop Talk Visit Shop Talk for all your general technical discussions regarding the Marauder!

Reply
 
Thread Tools Display Modes
  #1  
Old 10-12-2017, 09:19 AM
Cougar_Marauder's Avatar
Cougar_Marauder Cougar_Marauder is offline
Member
 

Join Date: Apr 2007
Location: Wisconsin
Age: 35
Posts: 339
Trader: (3)
Leaky injector

I believe I have a leaky injector. My car stalled on me 2 times now, both times I was sitting at a stop light and after a slight acceleration and letting off the throttle it stalled. The first time it happened I could smell gasoline (the tank was also nearly empty). I did some data recording but could not reproduce the problem. I would attach the files but it says they are invalid type... Later I checked my catch can and I believe there was some gas in it as well as the dip stick smelling slightly gassy. There are no engine lights and it otherwise seems to be running OK.

Where do I go from here to be sure and find the leaking injector? I have seen videos of listening for the ticking and checking the ohms but haven't done that yet. I know that can help find a "bad" injector but would it find a leaking one? Any help would be appreciated!

Also the engine was rebuilt a couple years ago with a Trilogy (60lb injectors) tuned by Lidio.
__________________
#3538 of 7838
Trilogy #238
Build date:8/14/02 - Bought:4/5/07

Last edited by Cougar_Marauder; 10-16-2017 at 01:29 PM.
Reply With Quote
  #2  
Old 10-12-2017, 07:16 PM
justbob's Avatar
justbob justbob is offline
Sick-Speed play toy
 

Join Date: Mar 2008
Location: Couple of car lengths ahead of you
Age: 44
Posts: 18,093
Trader: (11)
If it's stalling and your smelling gas I'd look into the FRPS.


Sent from my iPhone using Tapatalk
__________________


Cobra short block / ProCharger F1-A / Cog drive upgrade / Manley valves / Brian Tooley Racing valve springs / 80# inj. / -8 fuel line / -6 return / Aeromotive 340 pumps and regulator / 2012 GT500 TR6060 six speed / twin disc clutch / Driveshaft Shop GT500 upgraded CV joint shaft / BA5000 blow thru MAF/ 4.10's / Ford Racing 31 spline set up and Girdle / Metco D.S. safety loop / Stainless Works headers, cats, and everything else out back / ClassGlass hood / Bob's hood strut mod / Hurst line lock / Metco control arms / Addco front and rear sway bars / Monroe severe duty shocks all around / Race concepts rotors / Badgeless grille / 35% tint / FBM's interior LED kit and ambient lighting kit / Pioneer FB700 deck / kenwood speaker 4 Ch. / Rockford Fosgate 10" sub and amp / Kicker 6 X 8's all around / back up cam / bluetooth / Pioneer Xm / 704 RWHP 603 RWTQ tuned by Mo's Speedshop.
Reply With Quote
  #3  
Old 10-16-2017, 01:41 PM
Cougar_Marauder's Avatar
Cougar_Marauder Cougar_Marauder is offline
Member
 

Join Date: Apr 2007
Location: Wisconsin
Age: 35
Posts: 339
Trader: (3)
I only smelled gas while waiting at the stop light just before the first time it stalled.
I checked for any fuel smell in the vacuum hose attached to the FRPS and there was none. I also took the FRPS off to try and blow through it and I couldn't. There didn't appear to be any pressure in the rail when I removed it but I haven't started the car in over a week now. I have a fuel pressure gauge on the way.
__________________
#3538 of 7838
Trilogy #238
Build date:8/14/02 - Bought:4/5/07
Reply With Quote
  #4  
Old 10-16-2017, 05:04 PM
BLACKMARAUDER04's Avatar
BLACKMARAUDER04 BLACKMARAUDER04 is online now
Member
 

Join Date: Sep 2005
Location: Lake Balboa, CA
Age: 53
Posts: 932
Trader: (0)
check your air idle valve. It can cause stalling.
Reply With Quote
  #5  
Old 11-06-2017, 03:00 PM
Cougar_Marauder's Avatar
Cougar_Marauder Cougar_Marauder is offline
Member
 

Join Date: Apr 2007
Location: Wisconsin
Age: 35
Posts: 339
Trader: (3)
So I'm back to square one on this. I did the sound check on all my injectors and they sound good. I put a fuel pressure gauge on the rail where the Schrader valve was and it is only reads 30psi but data logging shows me at 40psi, so I bought a new FRPS. No change with the new sensor. So did I get a bum gauge? or could this be a sign of a failing pump? I also tried cranking up the boost-a-pump but that made no difference. The pump is an Aeromotive Stealth 340, maybe 2 years old.
__________________
#3538 of 7838
Trilogy #238
Build date:8/14/02 - Bought:4/5/07
Reply With Quote
  #6  
Old 11-06-2017, 03:07 PM
Turbov6Bryan's Avatar
Turbov6Bryan Turbov6Bryan is online now
meow meow meow
 

Join Date: Nov 2014
Location: Independence missouri
Age: 42
Posts: 2,411
Trader: (3)
There's a local guy here that cleans injectors for 10 bucks each plus shipping

Lsxkilr custom calibrations

They are on Facebook too

If it's dying I would put a gauge on it, and watch the fuel pressure. I bet the 2 year old fuel pump is dying.. use a gauge and a buddy
__________________
The twins2.3 whipple/aluminatorVortech V-2 lots of goodies
Reply With Quote
  #7  
Old 11-06-2017, 04:04 PM
Fastbob's Avatar
Fastbob Fastbob is offline
Senior Member
 

Join Date: Oct 2014
Location: Cunningham, Kansas
Age: 64
Posts: 555
Trader: (0)
Quote:
Originally Posted by Turbov6Bryan View Post
There's a local guy here that cleans injectors for 10 bucks each plus shipping

Lsxkilr custom calibrations

They are on Facebook too

If it's dying I would put a gauge on it, and watch the fuel pressure. I bet the 2 year old fuel pump is dying.. use a gauge and a buddy
Or a gauge duct taped to the windshield so you can see it.
__________________
2004 SB #2150 of 3214 Moonroof, Heated Seats and 6 CD Changer. Non OEM Mufflers and 30,XXX miles and counting.
Reply With Quote
  #8  
Old 11-06-2017, 04:17 PM
ByronRACE ByronRACE is offline
Senior Member
 

Join Date: Feb 2007
Age: 48
Posts: 182
Trader: (1)
If you think you have a leaky injector, pull all 8 plugs, remove all 8 coils, cycle the key on and off about 50 times to cycle the pump, then hold the throttle to the floor and crank it for a second. The hole that shoots fuel out is where the leaker is. Holding the throttle floored during cranking turns all 8 injectors OFF. Caution; you CAN bend a rod if you do this with the plugs in and a bore is full of fuel. It can hydraulically lock the engine at a point where the leverage on the small end of the rod during cranking is high enough to bend it. We had the misfortune of this happening after installing brand new ACCEL injectors in a brand new Cobra back in the day. The mechanic keyed on a few times and witnessed weird fuel pressure behavior, saw no leaks, then cranked it anyway. BANG.

Last edited by ByronRACE; 11-06-2017 at 04:24 PM.
Reply With Quote
  #9  
Old 11-07-2017, 06:03 AM
Fastbob's Avatar
Fastbob Fastbob is offline
Senior Member
 

Join Date: Oct 2014
Location: Cunningham, Kansas
Age: 64
Posts: 555
Trader: (0)
I would think that if you have a leaky injector there should be evidence of that on the sparkplug in the affected cylinder. Perhaps remove all the plugs, take a close look for deposits and compare their color.
__________________
2004 SB #2150 of 3214 Moonroof, Heated Seats and 6 CD Changer. Non OEM Mufflers and 30,XXX miles and counting.
Reply With Quote
  #10  
Old 11-07-2017, 09:35 AM
FordNut's Avatar
FordNut FordNut is offline
Contributing Member
 

Join Date: Jan 2003
Location: Near Knoxville TN
Age: 60
Posts: 10,609
Trader: (17)
As for the pressure gauge, it probably reads fuel rail referenced to atmosphere. The FRPS (and PCM) reads fuel rail referenced to vacuum. About 10 psi difference.
__________________
Thanks to Darrin @ BC Automotive:
$1800 and it was worse than when he started!

Brian (FordNut) FPG # 1458 of 7838
03 MM 300A (Lotsa mods, 130k mi) was 303rwhp/318rwtq N/A
then 476/410 D1SC ProCharged on stock block
then 660/555 D1SC PC on 5.3 wet sleeved Teksid alum big bore stroker
then 365/369 N/A on 5.3 wet sleeved Teksid alum big bore stroker
Now 751/617 3.4L Whipple on 5.3 Boss5.0 iron big bore stroker

03 MM 300B Silver (Mostly stock, wife's car, 289k mi) FPG # 7053 of 7838 or 49 of 417 SB
03 MM 300B Silver, Stock, 35k mi FPG # 7134 of 7838 or 89 of 417 SB
01 F150
00 F150 4x4
68 Stang FB (70 351C 4V, 4 wheel discs, project car)
94 Kawasaki ZG1000 Concours

Mods listed here (some items not current): FordNut's Mods
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Leaky Windshield Washer Ross Shop Talk 6 10-16-2016 06:48 AM
Leaky Head 510paesan Shop Talk 6 08-23-2016 04:21 PM
Ever have a leaky oil filter adapter? Capt Jake Shop Talk 6 02-07-2012 10:20 AM
Leaky rear shock. Rockettman Suspension & Brakes 5 10-30-2008 08:16 PM
tailshaft leaky leaky after personal best at bradenton Mills Marauder Shop Talk 11 02-27-2008 05:49 AM


All times are GMT -7. The time now is 03:06 PM.


Powered by: vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©2002 - 2017 - MercuryMarauder.net