MercuryMarauder.net Forums    

Go Back   MercuryMarauder.net Forums > The Garage > Shop Talk

Shop Talk Visit Shop Talk for all your general technical discussions regarding the Marauder!

Reply
 
Thread Tools Display Modes
  #1  
Old 04-20-2017, 09:30 PM
cashmonkey38's Avatar
cashmonkey38 cashmonkey38 is offline
Noobin' it up
 

Join Date: Sep 2013
Location: Austin, TX
Posts: 91
Trader: (0)
Question Half of instrument cluster lights not working

Another random problem has popped up on the car. I switched to LED lights a few years ago. The ones I got were crappy and slowly starting going out after a year tops - the lights would flicker and flicker and eventually go all the way out. I am replacing all lights now, but when I replaced the illumination lights that went out in the instrument cluster, only 2 of them are working. I believe all of the warning lights are working, it's just the illumination lights. As you can see in the pic, only the one near fuel gauge and trip meter are working. Thus I can't see top of speedometer or RPM's at night.

If I take the fixture holding the bulb from a non-working section and put it into a working section, they light up fine, so does not appear to be bulbs or the bulb holders. Yes plugs are all the way in, jiggling things does not cause lights to light up either. Fuses all seem to be fine but I wouldn't think the illumination lights would be on a different fuse anyway?

Any idears?
__________________
Maraudin' for Vengeance!
Reply With Quote
  #2  
Old 04-20-2017, 09:37 PM
cashmonkey38's Avatar
cashmonkey38 cashmonkey38 is offline
Noobin' it up
 

Join Date: Sep 2013
Location: Austin, TX
Posts: 91
Trader: (0)
Forgot pic
Attached Images
File Type: jpg IMG_2989a.jpg (71.5 KB, 28 views)
__________________
Maraudin' for Vengeance!
Reply With Quote
  #3  
Old 04-21-2017, 05:06 AM
justbob's Avatar
justbob justbob is offline
Sick-Speed play toy
 

Join Date: Mar 2008
Location: Behind that famous burrito joint
Age: 43
Posts: 17,559
Trader: (11)
Half of instrument cluster lights not working

LED bulbs only work inserted one way. Flip them 180*

They only work in other holes because the wiring is reversed.

Sent from my iPhone using Tapatalk
__________________


Cobra short block / ProCharger F1-A / Cog drive upgrade / Manley valves / Brian Tooley Racing valve springs / 80# inj. / -8 fuel line / -6 return / Aeromotive 340 pumps and regulator / 2012 GT500 TR6060 six speed / twin disc clutch / Driveshaft Shop GT500 upgraded CV joint shaft / BA5000 blow thru MAF/ 4.10's / Ford Racing 31 spline set up and Girdle / Metco D.S. safety loop / Stainless Works headers, cats, and everything else out back / ClassGlass hood / Bob's hood strut mod / Hurst line lock / Metco control arms / Addco front and rear sway bars / Monroe severe duty shocks all around / Race concepts rotors / Badgeless grille / 35% tint / FBM's interior LED kit and ambient lighting kit / Pioneer FB700 deck / kenwood speaker 4 Ch. / Rockford Fosgate 10" sub and amp / Kicker 6 X 8's all around / back up cam / bluetooth / Pioneer Xm / 704 RWHP 603 RWTQ tuned by Mo's Speedshop.
Reply With Quote
  #4  
Old 04-21-2017, 10:22 AM
fastblackmerc's Avatar
fastblackmerc fastblackmerc is offline
Everything Marauder, LEDs & HI
 

Join Date: Jan 2004
Location: Somewhere in the N.C. Triangle
Age: 61
Posts: 24,647
Trader: (73)
What justbob said and it looks like you need quality LED bulbs.
__________________
“When you can’t make them see the light, make them feel the heat.”
Ronald Regan

"The only way to deal with the Islamic State - these blood thirsty, blood-drunken, terrorists -
is to kill them, keep on killing them, until you kill the last one, then you kill his pet goat."

Lt. Colonel Ralph Peters

“Be polite, be professional, but have a plan to kill everybody you meet.”
"I come in peace. I didn't bring artillery. But I'm pleading with you, with tears in my eyes, if you **** with me, I'll kill you all"
General James Mattis



Reply With Quote
  #5  
Old 04-21-2017, 12:32 PM
cashmonkey38's Avatar
cashmonkey38 cashmonkey38 is offline
Noobin' it up
 

Join Date: Sep 2013
Location: Austin, TX
Posts: 91
Trader: (0)
Hmm I had thought about checking that - the thing is that I replaced all of the lights in the car, and all of them are working fine except for the ones noted in the instrument cluster, so I figured surely I did not happen to only mismatch the ones in there? And then assumed they must be able to be put in either way - I will check and update if that's the fix, thanks for the replies

EDIT: That was it!!
__________________
Maraudin' for Vengeance!

Last edited by cashmonkey38; 04-22-2017 at 10:48 PM. Reason: update
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Feed back tail lights not working but brake lights work Gerry24 Interior Electrical/Electronics 12 12-28-2016 07:02 PM
Interior lights & key pad not working LUCKY GENE Interior Electrical/Electronics 10 12-23-2016 03:20 AM
Adding an oil pressure idiot light, Part 1 drgnrdr33 Shop Talk 9 09-25-2008 06:00 AM
Marauder Instrument Cluster jsvic Other Parts/Misc. Wanted 0 09-01-2007 11:29 AM
Instrument Gauge Cluster and Speedometer blackf0rk Shop Talk 4 01-30-2006 12:28 AM


All times are GMT -7. The time now is 04:55 PM.


Powered by: vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright ©2002 - 2017 - MercuryMarauder.net